Mantine Hooks

Hooks for state and UI management
License

Installation

Package depends on react and react-dom.

Install with npm:

npm install @mantine/hooks

Install with yarn:

yarn add @mantine/hooks

Hooks by category

Browser support

All hooks are tested to work in all major modern browsers. Some hooks depend on web APIs that may not be supported by old browsers:

Build fully functional accessible web applications with ease
Feedback
Your feedback is most valuable contribution to the project, please share how you use Mantine, what features are missing and what is done good
Leave feedback